Author Topic: Solutions for disconnects issues for ArmA 3  (Read 14699 times)

G. E. Miller

  • Posts: 377
Solutions for disconnects issues for ArmA 3
« on: February 17, 2015, 08:40:42 PM »
Crash number 1:
When joining the game, your loading bar gets stuck halfway and will stop loading, after a while your ArmA 3 will stop working.
 
Solution:
 
Go to your windows search bar and type in %AppData%

 
 
 
Now you'll see this in the top left corner:
 

 
Click on AppData.
 
Now click on Local and after you did this search for ArmA 3.
You'll see this:
 

 
 
Delete the MPMissionCache folder completly.
This will clear your Multiplayer Cache and will make you re-download the mission file. Usually this will fix everything.
After you've deleted this folder, start up ArmA 3 again and re-join the server. You will be able to join again.
 
 
 
 
 
 
Crash number 2:
Frequently getting kicked for the error: Steam Ticket check failed: (null)
 
Solution:
 
First, you want to locate your Steam Directory.
In my case that is:

 
Now you want to click Common and look for ArmA 3.
After you've done this you will delete PhysX3_x86.dll
 

 
 
After you've done this, go to Steam and rightclick on ArmA 3 and click Properties. Then go to the tab Local Files and click the button that tells you to let steam verify your game for missing files.
Once this is over, you got a brand new .dll file and you are ready to go!
 
Hopefully this will help you all out.

Reference: http://www.gaming-asylum.com/forums/index.php?/topic/22209-for-anyone-who-experiences-arma-3-crashes-the-solutions-are-here/

WO1 (Ret) Greene

  • 153A Rotary Wing Aviator
  • Retired
  • Posts: 22
Re: Solutions for disconnects issues for ArmA 3
« Reply #1 on: February 23, 2016, 07:41:50 PM »
It will let me load into game most of the time but it does say i was lick just the memory cant me written and it gives a series of letters,number and symbols.
C. GREENE
WO1, USAF
Retired


S. Murphy

  • Posts: 253
Re: Solutions for disconnects issues for ArmA 3
« Reply #2 on: February 24, 2016, 03:11:56 AM »
I believe I am getting the Same issues on the Official Server for Operations and have no idea why.  I can attend Training etc..  But the Official Server is a No Go.  SO I'm not the most astute individual when it comes to this but I'll try.

I apologize for it's size!

Carrera

  • Posts: 102
Re: Solutions for disconnects issues for ArmA 3
« Reply #3 on: February 24, 2016, 08:19:51 AM »
for those having memory issues while trying to load into official servers try setting up your malloc files in your launcher this way:

for the "Vanilla Launcher":


ArmA3sync:

1LT (Ret) Ryan

  • 11A Infantry Officer
  • Retired
  • Posts: 374
Re: Solutions for disconnects issues for ArmA 3
« Reply #4 on: February 24, 2016, 09:47:58 AM »
A few things that may help.

1) Deleting all memory allocator's located in the dll folder that is located in your Arma 3 folder. DO NOT DELETE THE README FILE. Remember that every time the game updates, or you re-validate the install it will put those files back.

2) Specifically with 1.56 update, remember to update your graphics card driver.

3) After updating it is always a good idea to re-validate and defragment your HDD or SSD.

4) Make sure you are not launching with battle eye enabled.
J. RYAN
1LT, USA
Retired